








<!doctype html>
<!-- Engine: Aestiva HTML/OS Version 4.76 Developer Edition -->
<html lang="en">






 
 <head>


  <META http-equiv="Content-Type" content="text/html; charset=UTF-8" />
  <META NAME="author" content="McKenzie River Reflections" />
  <META NAME="description" CONTENT="VIDA: A pedestrian lost his life when he was hit by a car last Friday night. According to Oregon State Police reports, the accident occurred fatality" />
  <META NAME="keywords" CONTENT="" />
  <META NAME="robots" CONTENT="index,follow" />
  <META HTTP-EQUIV="cache-control" CONTENT="private, no-store, no-cache, must-revalidate" />
  <META NAME="revisit-after" CONTENT="45 days" />
  
  <META PROPERTY="og:title" CONTENT="Vida man killed in late night wreck">
<META PROPERTY="og:description" CONTENT="VIDA: A pedestrian lost his life when he was hit by a car last Friday night. According to Oregon State Police reports, the accident occurred fatality on Thursday, March 28th, at approximately 11:45 p.m. Police and emergency personnel responded to the scene on the McKenzie Highway near milepost 31 and Bear Creek. The preliminary investigation says t...">
<META PROPERTY="og:url" CONTENT="https://www.mckenzieriverreflectionsnewspaper.com/story/2019/04/03/police/vida-man-killed-in-late-night-wreck/3196.html">
<META PROPERTY="og:site_name" CONTENT="McKenzie River Reflections">
<META PROPERTY="og:type" CONTENT="website">
<META PROPERTY="og:image" CONTENT="https://www.mckenzieriverreflectionsnewspaper.com/home/cms_data/dfault/images/companylogo_facebook.png">
  <title>Vida man killed in late night wreck - McKenzie River Reflections</title>
  
      <meta name="viewport" content="width=device-width, initial-scale=1">
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/css_themes/white-3col/white-3col.css" />
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/pdf_click_menu_small.css" />

      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/slick/slick.css" />      
      <link rel="stylesheet" type="text/css" media="screen" href="/app/website_specifics/slick/slick-theme.css" />
         <link rel="stylesheet" type="text/css" media="screen" href="/home/cms_data/dfault/configuration_files/css_customizations/white/white.css" />
         <link rel="stylesheet" type="text/css" media="print" href="/app/website_specifics/print.css" />

<!-- Desktop/canonical vs. mobile/alternate URLs -->
<link rel="alternate" media="only screen and (max-width: 640px)" HREF="https://www.mckenzieriverreflectionsnewspaper.com/story/2019/3/4/police/vida-man-killed-late-night-wreck/3196.html?m=true">


<link rel="stylesheet" type="text/css" href="/app/website_specifics/fonts/font-awesome-4.6.1/css/font-awesome.min.css"/>
   <script src="/app/website_specifics/jquery-2-2-2.min.js"></script>
 <script src="/app/website_specifics/slick.js"></script>
   <script src="/app/website_specifics/lionslight.js"></script>

    <script>

     function offsiteLink(a,b){
      a.href='/ajax/selectit?storyId='+b;
      return false;
     }
     function offsiteAdLink(a,b){
      a.href='/ajax/adselectit?adid='+b;
      return false;
     }


     debug=false;


     function expiredAJAX() {
      // noop
     }


     function RemoveContent(d) {document.getElementById(d).style.display = "none";}
     function InsertContent(d) {document.getElementById(d).style.display = ""; swapdiv(d);}

     function swapdiv(a){
      if (a=='div2'){
       CLEAR.f.runOverlay('/ajax/popular/blogged');
      } else {
       CLEAR.f.runOverlay('/ajax/popular/viewed');
      }
     }

    
    </script>

  
  <!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-39523992-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-39523992-1');
</script>
<script>$(function() {
    var submitIcon = $('.searchbox-icon');
    var inputBox = $('.searchbox-input');
    var searchBox = $('.searchbox');
    var isOpen = false;
    submitIcon.click(function () {
        if (isOpen == false) {
            searchBox.addClass('searchbox-open');
            inputBox.focus();
            isOpen = true;
        } else {
            searchBox.removeClass('searchbox-open');
            inputBox.focusout();
            isOpen = false;
        }
    });
    submitIcon.mouseup(function () {
        return false;
    });
    searchBox.mouseup(function () {
        return false;
    });
    $(document).mouseup(function () {
        if (isOpen == true) {
            $('.searchbox-icon').css('display', 'block');
            submitIcon.click();
        }
    });


 runIf($('.menu').length,'jQuery.sticky','/app/website_specifics/sticky.js',function(){
  $(".menu").sticky({ topSpacing: 0, center:true, className:"stickynow" });
 });



});
function buttonUp() {
    var inputVal = $('.searchbox-input').val();
    inputVal = $.trim(inputVal).length;
    if (inputVal !== 0) {
        $('.searchbox-icon').css('display', 'none');
    } else {
        $('.searchbox-input').val('');
        $('.searchbox-icon').css('display', 'block');
    }
}












runIf=function(condition,name,url,callback){
 if(condition){
  runSafe(name,url,callback);
 }
}







runSafe=function(name,url,callback){
 if(typeof window[name] != 'undefined'){
  callback();
 } else {
  if(typeof runsafe != 'object'){runsafe={};}
  if(runsafe[url] && runsafe[url].constructor === Array){var loadit=false;} else {runsafe[url]=[];var loadit=true;}
  runsafe[url].push(callback);
  // START001 UI stuff not necessary
  // if (document.body){document.body.style.borderTop="10px solid red";}
  // END001 UI stuff not necessary
  if (loadit){
   var js = document.createElement('script');
   js.async = true;
   js.src = url;
   js.onload = js.onreadystatechange = (function(){return function(){
    while(runsafe[url].length){
     var f=runsafe[url].shift();
     f();
    }
    delete runsafe[url];
    var count = 0; for (var k in runsafe) if (runsafe.hasOwnProperty(k)) count++;
    if(count==0){
     // START002 UI stuff not necessary
     if (document.body){document.body.style.borderTop="none";}
     // END002 UI stuff not necessary
    }
   }})();
   var first = document.getElementsByTagName('script')[0];
   first.parentNode.insertBefore(js, first);
  }
 }
}










</script>

<style>
  
  .preLoadImg {
    display: none;
  }

#undefined-sticky-wrapper:before {
 height:50px;
 background-color: #B6BD98;
}


</style>

<!-- CSS for print_sub_alert -->
<style>

.print_sub_container {
    width:auto;
}
.print_sub_container div {
    width:auto;
}
.print_sub_container .print_sub_header {
    background-color:#c7edfc;
    padding: 12px 2px;
    cursor: pointer;
    font-weight: bold;
}
.print_sub_container .print_sub_content {
    display: none;
    padding : 5px;
}

</style>




 </head>
 <body id="mobile_false">


<img class="preLoadImg" src="/home/cms_data/dfault/images/home-menu-icon.png" width="1" height="1" alt="" />
<img class="preLoadImg" src="/home/cms_data/dfault/images/home-menu-active-icon.png" width="1" height="1" alt="" />



<!-- BEGIN TEXT THAT APPEARED BEFORE THE MAIN DIV. -->
<!--GOOGLE_SURVEYS_TEXT (00340)-->

<!-- END TEXT THAT APPEARED BEFORE THE MAIN DIV. -->


  <div class="container container_3">
   <div class="outer_standard_links outer">
   <div class="standard_links inner widen_vertical_padding skel">
    <div class="standard_links_left">
     <p class="wide_spacing small align_left">
      <a  href="https://www.mckenzieriverreflectionsnewspaper.com/classifieds" >Classifieds</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/directory" >Directory</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/photos" >Photos</a><a  href="https://store.mckenzieriverreflectionsnewspaper.com"  target="_blank">Store</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/about" >About</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/contact" >Contact</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/advertise" >Advertise</a>
     </p>
    </div>
    <div class="standard_links_middle">
     <p class="wide_spacing small align_center">
      <a  href="https://www.facebook.com/McKenzieRiverReflections"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/facebook.png'  height='21' alt=''></a><a  href="https://twitter.com/mckreflections"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/twitter_white.png'  height='19' alt=''></a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/rss"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/rss.png'  height='21' alt=''></a>
     </p>
    </div>
    <div class="standard_links_right">
     <p class="wide_spacing small align_right">
      <a  href="https://www.mckenzieriverreflectionsnewspaper.com/trial" >Free Trial</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/subscribe" >Subscribe</a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/login?r=%2Fstory%2F2019%2F3%2F4%2Fpolice%2Fvida%2Dman%2Dkilled%2Dlate%2Dnight%2Dwreck%2F3196%2Ehtml" >Sign In</a>
     </p>
    </div>
   </div>
   </div>
   

   <!--/// Header ///-->
   <div class="outer_header widen_vertical_width outer">
   <div class="header widen_vertical_padding inner skel">
    <h1>McKenzie River Reflections - Make the McKenzie Connection!</h1>
    <a href="https://www.mckenzieriverreflectionsnewspaper.com/">
     <div class="header_story_logo">
 <!--<img src='/home/cms_data/dfault/images/masthead_260x100.png' alt="">-->
     </div>
    </a>
 
    <div class="header_story_ad"><a href="https://www.mckenzievalleypump.com/" target="blank"><img src="/IMG/yGr-AEcIDcE95kOyHsBDA7NUFXSQW/XPATH/home/cms_data/dfault/web_ads/horiz/9741-mck_valley_pump_large_horizontal_ad.jpgXEXT1810x51511is.jpeg" width="728" height="90" alt=""></a></div>
 
   </div>
   </div>
 
   <div class="outer_search_bar outer">
   <div class="search_bar widen_vertical_padding inner skel">
    <div class="grid_2">
     <p class="small a2a_padding">
      
     </p>
    </div>
   </div>
   </div>
   <div class="outer_navigation outer">
    <div class="navigation inner skel">




<div class="menu widen_vertical_padding">
 <ul>
  <li class="home-menu-icon">
   <a class="" href="https://www.mckenzieriverreflectionsnewspaper.com/" data-tag="home"><span>Home</span></a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/news">News</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/sports">Sports</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/opinion">Opinion</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/history">History</a>
   <!--[if lte IE 7]><a href='#'>the_section<table><tr><td><![endif]-->
   <ul>
    <li>
     <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/history/off%5Fbeat%5Foregon%5Fhistory">Off Beat Oregon History</a>
    </li>
   </ul>
   <!--[if lte IE 7]></td></tr></table></a><![endif]-->
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/rec">Rec</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/doodles">Doodles</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/garden">Garden</a>
  </li>
  <li class="menu_right_border">
   <a class="active" href="https://www.mckenzieriverreflectionsnewspaper.com/section/police">Police</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/obits">Obits</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/video">Video</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/publications">Publications</a>
  </li>
  <li class="menu_right_border">
   <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/calendar">Calendar</a>
   <!--[if lte IE 7]><a href='#'>the_section<table><tr><td><![endif]-->
   <ul>
    <li>
     <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/calendar/church%5Fservices">Church Services</a>
    </li>
    <li>
     <a href="https://www.mckenzieriverreflectionsnewspaper.com/section/calendar/community%5Fevents%5Fcalendar">Community Events Calendar</a>
    </li>
   </ul>
   <!--[if lte IE 7]></td></tr></table></a><![endif]-->
  </li>
  <li id="new-search-white">
   <form method="GET" class="searchbox" autocomplete="on" ACTION="/findit" NAME="findit">
    <input class="searchbox-input" type="search" onkeyup="buttonUp();" placeholder="Search" name="mysearch" required="" value="">
    <input type="image" src="/app/images/search-img-icon-sm.png" name="mybutton" data-value="Search" class="searchbox-submit" alt="search">
    <span class="searchbox-icon"><img src="/app/images/search-img-icon-sm.png" class="searchbox-img" alt=""></span>
   </form>
  </li>
</ul>
 </div>
    </div>
    </div>
   <div class="outer_maincontent outer">
   <div class="maincontent widen_vertical_padding inner skel">
    <div class="maincontent skel">
     <div class="grid_2">
      <!--/// Begin Article from headline... ///--><!-- open the "right_border" div --><div class="right_border">	<div class='author'><p>		</p>
	</div><h2>Vida man killed in late night wreck</h2><div class='clear'>&nbsp;</div><!--/// CLEAR ///--><div class="title_separator"></div><div class="volume_issue">
<div class="a2a_kit a2a_kit_size_20 a2a_default_style single-social">
    <a class="a2a_button_facebook bothsociallink_border"><img src="/cms/images/social_media_icons/buttons/facebook_15_white.png" alt="facebook">&nbsp;&nbsp;Share</a>
    <a class="a2a_button_twitter bothsociallink_border"><img src="/cms/images/social_media_icons/buttons/twitter_13_on_15_white.png" alt="twitter">&nbsp;&nbsp;Tweet</a>
    <a class="a2a_button_pinterest bothsociallink_border" data-pin-config="none"><img src="/cms/images/social_media_icons/buttons/pinterest_15_white.png" alt="pinterest"></a>
    <a class="a2a_dd bothsociallink_border" href="https://www.addtoany.com/share" data-annotation="none"><img src="/cms/images/social_media_icons/buttons/addtoany_nobox_15_white.png" alt=""></a>
    <a class="comment_link_button bothsociallink_border" href="#readercomments" TAG="id-3196">0 Comments</a>

</div>
<script src="//static.addtoany.com/menu/page.js" async></script>
<p>April 3, 2019</p>

</div><br /><br /><div class="p402_premium"><P>VIDA: A pedestrian lost his life when he was hit by a car last Friday night. According to Oregon State Police reports, the accident occurred fatality on Thursday, March 28th, at approximately 11:45 p.m. Police and emergency personnel responded to the scene on the McKenzie Highway near milepost 31 and Bear Creek.<br /></P><P> The preliminary investigation says that a 1995 Mitsubishi Montero, operated by Randall Norris, 58, of Vida, was westbound on Hwy. 126 when he struck Michael Juden, 28, also of Vida, who was walking in the roadway.<br /></P><P> Juden sustained fatal injuries and was pronounced deceased.<br /></P><P> Norris is cooperating with the investigation.<br /></P><P> OSP was assisted by McKenzie Fire &amp; Rescuet and the Oregon Dept. of Transportation.</P><P>&nbsp;</P><P><em>McKenzie River Reflections</em></P><P></P></div><!-- close the "right_border" div --></div>
    <script> 
      try { _402_Show(); } catch(e) {} 
    </script><p class="skel"></p><div>
	<fieldset>
		<legend>You might be interested in:</legend><ul><li class='other_interest'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/police/sheriffs-report-may-13/3606.html' >Sheriff's Report - May 13</a></li><li class='other_interest'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/06/police/oregon-state-police-report-may-6/3591.html' >Oregon State Police Report - May 6</a></li><li class='other_interest'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/06/police/sheriffs-report-may-6/3590.html' >Sheriff's report - May 6</a></li><li class='other_interest'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/police/state-police-report-may-13/3607.html' >State Police Report - May 13</a></li><li class='other_interest'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/06/police/mckenzie-fire-and-rescue-report-may-6/3592.html' >McKenzie Fire & Rescue Report - May 6</a></li></ul></fieldset></div><div class="clear">&nbsp;</div><!--/// CLEAR ///--><!--END CONTENT AREA-->
     </div>
     
     <!--BEGIN SIDEBAR CONTENT AREA-->
     <div class="sidebar_grid align_center"><!--BEGIN SIDEBAR CONTENT AREA--><div id="most_popular"><table style="width:100%;"><tr><th colspan="2">Most Popular</th></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/local-for-gov/3602.html'><img src="/IMG/b1r-zqPi2I4AwWyO-9C8B4Bw9/XPATH/home/cms_data/dfault/photos/stories/id/0/2/3602/s_topXEXT1708x41376is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/local-for-gov/3602.html'>Local for Gov?<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/fire-related-theft-suspects-wont-be-going-to-trial/3603.html'><img src='/home/cms_data/dfault/images/mostpopular_default_photo_67x50.jpg' width='67' height='50' alt=''></a></td><td class='mp_article' style='width:75%;'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/fire-related-theft-suspects-wont-be-going-to-trial/3603.html'>Fire-related theft sus...<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/police/sheriffs-report-may-13/3606.html'><img src='/home/cms_data/dfault/images/mostpopular_default_photo_67x50.jpg' width='67' height='50' alt=''></a></td><td class='mp_article' style='width:75%;'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/police/sheriffs-report-may-13/3606.html'>Sheriff's Report - May 13<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/road-maintenance/3600.html'><img src="/IMG/Mmgn-zS2xHmA0izG5sB8I4-wt/XPATH/home/cms_data/dfault/photos/stories/id/0/0/3600/s_topXEXT1708x41384is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/road-maintenance/3600.html'>Road maintenance<span class='mp_author'></span></a></td></tr>
<tr><td class='mp_photo' style="width:25%;"><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/aufderheide-drive-remains-closed/3614.html'><img src="/IMG/l_g21yU63BmExoqItsQ6Q3pwr/XPATH/home/cms_data/dfault/photos/stories/id/1/4/3614/s_topXEXT1723x41430is.jpg" width="67" height="50" alt=""></a></td><td class='mp_article' style='width:75%;'><a href='https://www.mckenzieriverreflectionsnewspaper.com/story/2021/05/13/news/aufderheide-drive-remains-closed/3614.html'>Aufderheide Drive rema...<span class='mp_author'></span></a></td></tr>
</table></div><div class="side_separator ss_invisible"></div><div class="sticky_ad_square"><a href="https://mckenziediscoverycenter.org/" target="blank"><img src="/IMG/ylYlgV6kYjeRZRmNmxVtmHgHwppzDwvno/XPATH/home/cms_data/dfault/web_ads/square/6430-mrdc_square_ad.jpgXEXT1535x43600is.jpeg" width="300" height="259" alt=""></a></div><div class="side_separator"></div><div id="rc-widget-2b3b27" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="176003"></div><script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script><div class="side_separator"></div><!--END SIDEBAR CONTENT AREA-->
     </div>
     <!--END SIDEBAR CONTENT AREA-->
    </div>
   </div>
   </div>




   <div class="bottom_banner_ad widen_vertical_width skel"><!--//////////////////// START READER COMMENTS ////////////////////-->
<a id='readercomments'></a><div class='comments'><h2>Reader Comments<span class="comment-top-text-left">(0)</span></h2><div class="comment-top-text-right align_right">
		<a href='https://www.mckenzieriverreflectionsnewspaper.com/login?r=%2Fstory%2F2019%2F3%2F4%2Fpolice%2Fvida%2Dman%2Dkilled%2Dlate%2Dnight%2Dwreck%2F3196%2Ehtml'><img src='/cms/images/comment_icon.gif' alt='comment'> Log in to add your comment</a></div><div class="clear">&nbsp;</div><!--/// CLEAR ///--><div class="clear">&nbsp;</div><!--/// CLEAR ///--><div class="bottom_banner_ad"><div class="bottom_banner_advert_text"><a href="https://www.realtor.com/realestateagents/sally-blaze___3224701_649764397" target="blank"><img src="/IMG/9RxHGDlLCW3BDp62-hU7N49F_kdWU/XPATH/home/cms_data/dfault/web_ads/horiz/5419-blaze_large_horizontal_ad.jpgXEXT1683x47976is.jpeg" width="728" height="90" alt=""></a></div></div></div><!--Story_full--></div>



   <div class="outer_footer outer">
   <div class="footer widen_vertical_padding inner skel">

      <div class="footer_column_1">
        <h3>Sections</h3>
        <ul><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/news'>News</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/sports'>Sports</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/opinion'>Opinion</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/history'>History</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/rec'>Rec</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/doodles'>Doodles</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/garden'>Garden</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/police'>Police</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/obits'>Obits</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/video'>Video</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/publications'>Publications</a></li><li><a href='https://www.mckenzieriverreflectionsnewspaper.com/section/calendar'>Calendar</a></li>
        </ul>
      </div>


      <div class="footer_column_2">
        <h3>Newspaper</h3>
        <ul>
          <li><a href="https://www.mckenzieriverreflectionsnewspaper.com/contact" >Contact</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/subscribe" >Subscribe</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/about" >About</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/photos" >Photos</a></li><li><a href="https://store.mckenzieriverreflectionsnewspaper.com"  target="_blank">Store</a></li>
        </ul>
      </div>


      <div class="footer_column_3">
        <h3>Website</h3>
        <ul>
          <li><a href="https://www.mckenzieriverreflectionsnewspaper.com/terms" >Terms of Use</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/privacy" >Privacy Policy</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/sitemap_index.xml"  target="_blank">Sitemap</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/story/2019/3/4/police/vida-man-killed-late-night-wreck/3196.html?m=true" >Mobile Browser</a></li>
        </ul>
      </div>

      <div class="footer_column_4">
        <h3>Advertise</h3>
        <ul>
          <li><a href="https://www.mckenzieriverreflectionsnewspaper.com/advertise" >Advertise</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/directory" >Business Directory</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/advertise/placead" >Place a Classified Ad</a></li>
        </ul>
      </div>

      <div class="footer_column_5">
        <h3>Contribute</h3>
        <ul>
          <li><a href="https://www.mckenzieriverreflectionsnewspaper.com/contact" >Submit Content</a></li><li><a href="https://www.mckenzieriverreflectionsnewspaper.com/contact" >Letter to the Editor</a></li>
        </ul>
      </div>

      <div class="footer_column_6">
        <h3>Connect With Us</h3>
          <a  href="https://www.facebook.com/McKenzieRiverReflections"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/facebook.png'  height='30' alt=''></a><a  href="https://twitter.com/mckreflections"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/twitter.png'  height='28' alt=''></a><a  href="https://www.mckenzieriverreflectionsnewspaper.com/rss"  target="_blank"><img class='footer_icon' src='/cms/images/social_media_icons/rss.png'  height='30' alt=''></a>
        <h4>McKenzie River Reflections</h4>
        <p>
          59059 Old McKenzie Hwy.<br />McKenzie Bridge, OR 97413<br />Ph: (541) 822-3358<br />
       </p>
        <p>
          &copy; 2021 McKenzie River Reflections<br />
       </p>
      </div>


   </div>
   </div>
   <div class="outer_other_companies outer">
    <div class="other_companies widen_vertical_padding inner skel">

      <h3>Our Family of Publications Includes:</h3>

      <div class="slickcarousel_pubfamily">
<div><a  href="https://www.mckenzieriverreflectionsnewspaper.com" ><img class='footer_icon' src='/home/customer_files/images/publication_family/mck_mag_logo.jpg'  height='80' alt=''></a></div><div><a  href="https://www.mckenzieriverreflectionsnewspaper.com" ><img class='footer_icon' src='/home/customer_files/images/publication_family/mck_phone_book_logo.jpg'  height='80' alt=''></a></div><div><a  href="https://www.mckenzieriverreflectionsnewspaper.com" ><img class='footer_icon' src='/home/customer_files/images/publication_family/mck_travelers_guide_logo.jpg'  height='80' alt=''></a></div>
      </div>

    </div>
   </div>

 <div class="outer_footer2 outer">
   <div class="footer2 widen_vertical_width inner skel">


    <div class="roar_pub">
     <p>Powered by <strong><a href="http://www.lionslight.com" target="_blank">ROAR Online Publication Software</a></strong> from Lions Light Corporation<br />
     © Copyright 2020</p>
    </div>


   </div>
 </div>


  </div>
  

<script>

$('.slickcarousel_white').slick({
  dots: false,
  infinite: true,
  speed: 300,
  slidesToShow: 5,
  slidesToScroll: 1
});

$('.slickcarousel_pubfamily').slick({
  dots: false,
  infinite: true,
  speed: 300,
  slidesToShow: 3,
  slidesToScroll: 1
});



$(".more_stories_toggle").click(function () {
    this.style.margin = "0";
    $more_stories_toggle = $(this);
    $more_stories_list = $more_stories_toggle.next(); 							  //getting the next element

//    $more_stories_list.slideToggle("slow", function () {						  //open up the content needed - toggle the slide- if visible, slide up, if not slidedown.

        $more_stories_toggle.text(function () {								  //execute this after slideToggle is done; change text of header based on visibility of content div

            return $more_stories_list.is(":visible") ? "+ More Stories" : "- More Stories";               //change text based on condition
        });
//    });
});




</script>



<script>

//$(".more_stories_toggle").click(function () {
//
//    $more_stories_toggle = $(this);
//
//    //getting the next element
//    $more_stories_list = $more_stories_toggle.next();
//
//    //open up the content needed - toggle the slide- if visible, slide up, if not slidedown.
//    $more_stories_list.slideToggle(200, function () {
//
//        //execute this after slideToggle is done
//        //change text of header based on visibility of content div
//        $more_stories_toggle.text(function () {
//
//            //change text based on condition
//            return $more_stories_list.is(":visible") ? "- More Stories" : "+ More Stories";
//        });
//    });
//
//});

</script>

<script>

$( ".print_sub_container" ).click(function() {
  $( ".print_sub_content" ).slideToggle( 500, function() {
    // Animation complete.
  });
});

</script>

 <!-- <br><small>live</small> (Desktop|paywallfalse|full) -->
 </body>


</html>
